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1 Product overview
Arcserve Exchange Granular Restore Tool (AEGRT) is a granular data extraction software for offline Microsoft
Exchange Server mailbox stores. The utility provides direct access to unmounted mail store contents,
displaying file structure and its contents with selective export functionality.
Arcserve Exchange Granular Restore Tool can extract mailboxes, folders, messages and file attachments,
notes, contacts, tasks and appointments, creation dates for all objects and other attributes. Recovered items
can be saved into Personal Storage File (.pst) files, to be opened with Microsoft Outlook or other compatible
email clients, or exported directly into live Exchange Server mailboxes.
The utility makes no changes to the mail store, preserving it in original unmodified state.
Main features of Arcserve Exchange Granular Restore Tool:
·Recovers mailboxes, folders, messages and file attachments
·Recovers contents of Public Folder mailboxes
·Recovers notes, contacts, tasks and appointments
·Recovers creation dates for all objects
·Saves selected items to PST files or exports to live Exchange Server mailbox(es)
·Full install/uninstall support
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1.1 Supported Exchange database versions

Arcserve Exchange Granular Restore Tool supports the following mail store versions:

· Exchange 2019 CU14;

· Exchange 2019 CU13;

· Exchange 2019 CU12;

· Exchange 2019 CU11;

· Exchange 2019 CU10;

· Exchange 2019 CU9;

· Exchange 2019 CU8;

· Exchange 2019 CU7;

· Exchange 2019 CU6;

· Exchange 2019 CU5;

· Exchange 2019 CU4;

· Exchange 2019 CU3;

· Exchange 2019 CU2;

· Exchange 2019 CU1;

· Exchange 2019 RTM;

· Exchange 2016 CU23;

· Exchange 2016 CU22;

· Exchange 2016 CU21;

· Exchange 2016 CU20;

· Exchange 2016 CU19;

· Exchange 2016 CU18;

· Exchange 2016 CU17;

· Exchange 2016 CU16;

· Exchange 2016 CU15;

· Exchange 2016 CU14;

· Exchange 2016 CU13;

· Exchange 2016 CU12;

· Exchange 2016 CU11;

· Exchange 2016 CU10;

· Exchange 2016 CU9;

· Exchange 2016 CU8;

· Exchange 2016 CU7;

· Exchange 2016 CU6;

· Exchange 2016 CU5;

· Exchange 2016 CU4;

· Exchange 2016 CU3;

· Exchange 2016 CU2;

· Exchange 2016 CU1;
· Exchange 2016 RTM;
· Exchange 2013 CU23;
· Exchange 2013 CU22;
· Exchange 2013 CU21;
· Exchange 2013 CU20;
· Exchange 2013 CU19;
· Exchange 2013 CU18;
· Exchange 2013 CU17;
· Exchange 2013 CU16;
· Exchange 2013 CU15;
· Exchange 2013 CU14;
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· Exchange 2013 CU13;
· Exchange 2013 CU12;
· Exchange 2013 CU11;
· Exchange 2013 CU10;
· Exchange 2013 CU9;
· Exchange 2013 CU8;
· Exchange 2013 CU7;
· Exchange 2013 CU6;
· Exchange 2013 CU5;
· Exchange 2013 SP1;
· Exchange 2013 CU3;
· Exchange 2013 CU2;
· Exchange 2013 CU1;
· Exchange 2013 RTM;
· Exchange 2010 SP3;

· Exchange 2010 SP2;

· Exchange 2010 SP1;

· Exchange 2010 RTM;

· Exchange 2007 SP3;

· Exchange 2007 SP2;

· Exchange 2007 SP1;

· Exchange 2007 RTM.

1.2 System requirements

Basic system requirements:

· Operating systems: Windows 11, Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server
2025, Windows Server 2022, Windows Server 2019, Windows Server 2016, Windows Server 2012 R2,
Windows Server 2012, Windows Server 2008 R2 SP1, Windows Server 2008 SP2;

· Software: .NET Framework 4.6.2 or higher;

· RAM: 1024MB, depends on mail store size and OS version;

· Hard Disk: minimum 25MB of free space required for installation;

· Display: 800 x 600 or higher resolution, 256 colors.
Additionally, Arcserve Exchange Granular Restore Tool may require free space on disk 1.5x the size of mail
store being processed. For example, for 300MB mail store, 450MB free space should be available.

Live Exchange Server export requirements
Exchange Server
Exchange Server 2019, 2016, 2013, 2010 or 2007
Exchange Web Services enabled on Exchange Server
Network
Port 443 open on the network. The EWS messages are transported via SOAP-based API, which is essentially
sending XML data using https protocol.
Restore client
AEGRT installed. Access to Exchange server(s) over network.
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1.3 Limitations

Current version of the product has the following limitations:

· While processing dirty shutdown database storages may be restored not to the topical condition.

· Messages in the Outbox folder are not restored if they haven't been synchronized with the server.

· Simultaneous recoveries are not supported.

· Simultaneous running of more than one instance of the product is not supported.

· Encrypted emails are not restored.

· Messages with size over 64MB are not supported.

· Windows Vista, XP, 2000, 98, ME, 95 and 2003 Server are not supported.

· Recovery of delivery receipts and non delivery reports is not supported.

· Tool doesn't support usage in "Run as different user" mode.

· Restored contact group should located in folder, which is shown as an e-mail Address Book. 

· Approved status of Calendar Events is not supported.

· Links to the Exchange Global Address List are not supported.

· Exchange Server Databases: Preview items with 4-byte Unicode characters may be not full in product
started on Win7 and WS2008 OS. It is not affect on quality of restoring into PST or into live server.

· Exchange Server Databases: Search input field may work incorrectly with 4-byte Unicode characters. It
does not affect on results of search.

· Exchange Server Databases: Distribution lists linked to contacts are not supported.
Limitation and boundaries for optimal recovery and search
Usage of Arcserve Exchange Granular Restore Tool is optimal for datasets that do not exceed:

· Database size: 2TB.

· Mailbox size: 100GB.

· Number of messages in the database: 2,000,000.

· Number of mailboxes in the database: 2,000.

· Number of messages in one mailbox: 100,000.
Limitations for search in attachments content
Search in attachments does not work for:

· Text contained in embedded OLE objects, WordArt and smart objects, charts etc. Documents metadata
(author, comments, tags etc.). 

· Marker symbols in lists (numbered or bulleted).

· Text in header/footer.

· XLS/XLSX: number values, formulas, cell comments.

· PPT: tables content.
Limitations for search in double byte language:

· Search is "not" working when attachment name or attachment content is searched.

· Search is "not" working when Message Body is searched.

· Asterisk and Question Mark doesn't work in double byte language Search and doesn't supported in
Extended search mode.

Tip
Note that the utility is best used for granular item extraction. The user interface of the program is designed
for ease of locating, selecting and exporting specific messages, folders or mailboxes. Entire databases can
be exported as well, but the restore time will significantly increase over a slow connection. For bulk
operations that involve exporting more than one mailbox it is typically better to work with a local copy of the
database.
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Injection limitations
· Injection will not be supported for Exchange Server 2003 and earlier versions. These versions do not

support EWS.

· Archived mailboxes (and items from such mailboxes) are not exported to live Exchange Server.

· Photos of contacts are not exported to original live mailbox in Exchange Server 2007.

· Emails with embedded images and other OLE objects are displayed with an attachments icon after exporting
into live Exchange Server.

· Creation time and modified time are not restored.

· Attached items inside attached messages are not restored into live Exchange Server 2007.

· Impossible exporting into live Exchange Server embedded messages with more than 2 levels of nesting. 
Please use saving into PST for such items.

· Cross-domain export into original mailbox is not supported.

· Contact groups and meeting requests cannot be exported into live Exchange Server 2007 instances. Use
export through PST for these item types. 

· Contacts from contact group can be previewed only in cases: it was restored in original 'Contact' folder in
alternative mailbox (previewing for OWA and Outlook); it was restored into alternative folder ('Contact' type)
and folder has property 'Showed as e-mail Address book' (previewing for Outlook only).

· Missing sent date is exported as current date/time into live Exchange Server. 

· To restore a mailbox, an empty mailbox must be created in advance using the standard Exchange Server
administration tools. In existing mailboxes folders and individual messages can be created without any
additional administrative actions.

· It is possible to rename/delete folders in the attached mailbox only within one program session.

· It is impossible to use the connection to the archive mailboxes, as they can not be found in the Active
Directory.

· For IPM.Task class items "Update List" field is not restored after injection.
Recovery of the following item properties to live server may be incorrect, to avoid this problem it is
recommended to use Export to PST :

· InternetHeaders

· RTFCompressed

· Codepage

· DateCompleted (for IPM.Task class items existing "Date Completed" value is exported into live Exchange
Server as current date/time)

· TaskRecurrence

· RecurrencePattern

· AppointmentTimeZoneDefinitionEndDisplay

· ReminderTime

· CommonEnd

· AppointmentStartWhole

· AppointmentEndWhole

· BusyStatus

· Meeting Owner

· Company Name of Task

49
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1.4 Customer support

For customer support, please contact Arcserve using one of the methods listed below.

Online: https://support.arcserve.com

Email: support@arcserve.com

Phone

number:
https://support.arcserve.com/s/article/205390825

Tip
When contacting customer support with a technical issue, please have ready the program's log files and
the mail store you are having difficulty with.
Complete the following steps to gather logs:
1. Clear the existing contents of the log folder: File -> Delete saved temp files and logs
2. Enable debug logging: Options -> Debug logging

Debug logs are extended application-related logs, providing these to customer support team can
significantly speed up our analysis of any issues.

3. After debug logging has been enabled, you must restart Arcserve Exchange Granular Restore Tool and
then reproduce the issue.

4. After you have finished collecting extended debug logs, restart Arcserve Exchange Granular Restore
Tool and disable debug logging.

5. To get log files, click File menu and choose Open log folder. Zip the contents of the folder and attach
the resulting archive to your support request.
If the log archive and/or mail store exceeds 10MB, it may be impossible to send them as an email
attachment. In that case, upload instructions will be provided to you upon request.

https://support.arcserve.com
mailto:support@arcserve.com
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2 Opening a mail store
To directly open a mailbox store for browsing and export, launch Arcserve Exchange Granular Restore Tool
and click file open button on the taskbar or select File|Open from the menu. On first launch, the file open
dialog will be shown automatically.
Select the store you will be working with, specify path to database log files (if you have any) and click Open.

By default, a progress window will accompany opening the selected mailbox store. The window displays overall
progress and information about the number of mailboxes in the database (1). The window can be disabled by
unchecking the Show the dialog next time check box (2) or from the Options menu. The progress window
will be automatically closed in 3 seconds after database opening (3).

Current operation can be canceled right on the progress dialog, by clicking an appropriate link.
After loading the mailbox store is complete, the database will be available for browsing and export. The mailbox
store will also become the default store and will be automatically reopened next time you launch the utility.
Opened database can be reloaded with database log files. Go to the File menu and select Reload database
using transaction logs.
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Note
If you closed the progress window, it can easily be shown again by clicking on the progress bar on the
status panel.
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2.1 Finding a mail store

In case when the location of the file is unknown, it is recommended to scan existing drives to find the data. 
Arcserve Exchange Granular Restore Tool scans local drives, both mounted and unmounted, as well as
network drives and searches for EDB files.
To start a new search click Search for files to open in the File menu.

The following form appears, displaying the list of mounted disks:

To use unmounted disks (NTFS and FAT32 file systems are supported) for search, check Include
unmounted volumes. All unmounted volumes will appear in the list of disks.
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Note
Only NTFS and FAT32 file systems of unmounted drives are supported.

Select a location to search in.

List of found EDB files will be displayed. Double click on a mail store to open it.
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Note
To scan unmounted disks, the user, running the program, must have administrative rights.
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3 Special features
Usage of Arcserve Exchange Granular Restore Tool can be more comfortable for a user due to additional
Options menu, which allows user to customize program work.
Detailed information about every option is described in this help section.

3.1 PST encoding

Exporting mail store data into PST allows to select a PST format that suits your version of Microsoft Outlook.
Outlook 2019, 2016, 2013, 2010, 2007, 2003 process both Unicode and ANSI PST files, but as for older
versions such as Outlook 2002 and earlier, they will not be able to open Unicode-formatted PST files. Previous
versions of Outlook were using only ANSI format. The main reason for this change was to allow for
international character support and to extend the maximum size of PST files beyond the 2GB limit of the ANSI
formatted PST files.
In Arcserve Exchange Granular Restore Tool there are two ways to select suitable encoding for output PST.
Output PST encoding can be changed while selecting a destination folder for restored PST files.

Alternatively, encoding for the output file can be changed in the Options menu at any time the program runs.
Selected value will be saved and used on the next program launch.
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3.2 Incomplete messages

Incomplete messages, such as messages with missing properties, bodies, are hidden by default. This option
can be changed in the Options menu.

Note
After changing the way of displaying incomplete items, the database will be reopened.
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3.3 Showing system folders

System folders are hidden by default. This option can be changed in the Options menu.

Note
After changing the way of displaying system folders, the database will be reopened.
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3.4 Showing deleted items

Arcserve Exchange Granular Restore Tool provides an ability to process deleted items and folders.
This special feature can be enabled via the Options menu. There are three available display modes:

· non-deleted items - displays actual items in folders;

· show only deleted items - displays items/folders deleted from a mailbox hierarchy, but not physically;

· show both deleted and non-deleted items - displays both actual items in folders and items/folders deleted
from a mailbox hierarchy.

Note that after selecting any way of processing deleted items, the database will be reopened.
Items, deleted from Exchange Server 2010 and 2013 databases, are stored in the folder Deletions and have
an appropriate type.

As for items deleted from Exchange Server 2007 databases, they are stored in the their original folders but
can be easily recognized by an appropriate status.

Note
Items, stored in the folder Deletions, cannot be recovered to live Exchange Server database. It is
recommended to restore items from the Deletion folder to PST and then import to live Exchange Server.
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3.5 Display time

There are two dates display formats available for users, local time and GMT.
To switch dates display format between local computer time and GMT, use the Options menu.

If you switch display time, a warning, that the file will be reloaded, appears.

The same message in GMT format looks the following way:
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3.6 Showing notification panel

Every program action is accompanied by an appropriate notification for user. Notification panel is disabled by
default, but can be easily enabled by checking Show notification panel in the Options menu.

After that user will see additional information about opening file, export results, search results, etc.
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3.7 Language

Arcserve Exchange Granular Restore Tool supports the following display languages:

· English

· Japanese

· German

· Spanish

· French

· Italian

· Portuguese

· Chinese (Simple)

· Chinese (Traditional)

· Korean
Product language after installing is set to the same as "Display language" of operating system (in case
"Display language" is supported by product). Product language is set to default English language for
unsupported "Display language". Language can be changed in the Options menu.

Any changes in language settings will be saved for next start of product or installation of newer version.
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4 Finding and selecting messages, folders and mailboxes
Arcserve Exchange Granular Restore Tool provides two mutually complementary modes of finding, previewing
and selecting items: browsing the mailbox tree and search. Using these, it is possible to efficiently form a set
of items for subsequent export, including the necessary ones and excluding ones to be skipped.
A newly opened database is shown in the Browse mode.
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4.1 Browsing mail store tree

Browse mode shows mail store in a tree-like structure and allows browsing folders and previewing individual
items.
This mode is best for navigating to specific mailboxes, folders and messages when it is precisely known what
data needs to be extracted.
For example, a user may ask to restore a specific message from a known folder. Expand his or her mailbox in
the tree, select the folder, find and click the item. All available properties and information about the item will be
displayed in the Preview window to the right of the tree.

There is a check box next to the message. Check it to mark the message for export.
Continue to mark other items, folders and mailboxes for export in a similar way.

Use filtering feature for better browsing the list of items in a folder.
Enable filtering by pressing Ctrl+F buttons. A special panel will appear in the right part of the program
window.
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Use search in preview feature for quick find text in item preview.
Enable search in preview by pressing Ctrl+D keys after opening preview of item. A special panel will appear
in the right part of the program window.

Tip
Each individual item, folder and mailbox has a check box next to it. Using these check boxes, it is possible
to select as many or as few items for export as necessary.
To export an entire

· mail store, mark the root check box with the mail store name.

· mailbox, mark the check box next to mailbox in the tree.

· folder, expand a mailbox and mark the check box next to the desired folder.
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4.2 Using search

The search in the main window provides the ability to search single or multiple mailboxes and perform actions
on the search results.
The best application of search mode is when the location and/or number of items to extract is not known
exactly. Using keyword search, it is possible to narrow down on specific messages, folders and mailboxes.
The quickest way to get search results is clicking on a particular mailbox, entering some keywords in the
Search field and clicking the button Start search.
Search results will be displayed on a separate tab.

If a user knows exactly in what mailbox or folder the data is located, using Search in mailbox option will
speed up the search.
Right-click on a folder/a mailbox will open a context menu.
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By clicking on this menu advanced mode of search dialog will be opened and Search in field will be filled with
the selected mailbox/folder.
Fill in necessary search parameters and start the search.
For more precise searches click on the Search field, drop-down list of all search fields will appear:

· Search in - specifies mailbox(es)\folder(s) to search in. Default: entire database. If you select one or more
Search in check boxes, but specify no additional search criteria, the utility will return all items from the
selected folder(s).

· Has words - search for mail store items that have words or phrases entered in the field.

· Doesn't have - search for items that do not have words or phrases entered in the field.

· Has attachments - search for items with attachments.

· From - search for keywords in the From: field.

· To - search for keywords in the To: field.

· Subject - search for keywords in subject.

· Date range - set specific date range if known. It is obligatory to set both the beginning and the end of the
desired time period.

The outcomes of a search can be:
1. The program was able to find items (1) that corresponds to specified search parameters (2). The user can

select separate items or mark search results for recovery.
Clicking an item in the search results tab will open the item preview. Selecting item(s) in search results will
make their recovery possible.
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Counters of found elements are automatically updated or can be updated manually by clicking on the Refresh
button. If any folder is selected and the program has found new elements in it, then the following value will be
shown: previous(value, when we selected the folder) value of a counter + count(in green) of newly found
elements, which will be updated in real-time.

Words and phrases which match the search query are highlighted in the preview, which helps to easily
identify where the match was found.
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2. The search didn't match any items. Review search parameters and run another search.
To delete temporary data, generated by Arcserve Exchange Granular Restore Tool, go to the File menu and
click Delete saved temp and logs.

Note
Next search in the same folder/mailbox will be almost instant (only if saved search indexes and logs haven't
just been deleted).
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Note
Search with empty query is not available.

Note
Asterisk ('*') is added to all words in search fields by default. This allows to find not only specified words
but also their word forms. Use quotes (" ") to search for an exact phrase. 
Asterisk and Question Mark doesn't work in double byte language Search.

Note
Search is "not" working when attachment name or attachment content is searched and Message Body is
searched.
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Advanced search
Advanced search uses symbols and operators in queries. These operators allow you to find what you're
looking for quickly and accurately.
To use advanced search enter operators and their values into the Search field (1).

 
Operators are listed below:

Operator Definition Example

from: Used to specify the sender. Example: from:alex
Meaning: messages from Alex.

to: Used to specify a recipient. Example: to:John
Meaning: all messages that were sent to
John (by any user).

subject: Search for words in the subject
line.

Example: subject:dinner
Meaning: messages that have the word
"dinner" in the subject.

OR Search for messages matching
term A or term B.
OR must be in all caps

Example: from:alex OR from:john
Meaning: messages from Alex or from
John.

AND or Space Search for messages matching
term A and term B.
AND must be in all caps.

Example: from:alex AND from:john
Meaning: messages from Alex and from
John.

-
(hyphen)

Used to exclude messages from
your search.

Example: dinner -movie
Meaning: messages that contain the word
"dinner" but do not contain the word
"movie".

has:attachment Search for messages with an
attachment.

Example: from:john has:attachment
Meaning: messages from John that have
an attachment.
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Operator Definition Example

att_name: Search for messages with
specified attachment name.

Example: to:jane att_name:photo.png
Meaning: messages to Jane that have an
attachment with specified attachment
name.

cc:
bcc:

Used to specify recipients in the
cc: or bcc: fields
Search on bcc: cannot retrieve
messages on which you were blind
carbon copied.

Example: cc:John
Meaning: messages that were cc-ed to
John.

" "
(quotes)

Used to search for an exact
phrase*
*capitalization isn't taken into
consideration.

Example: "i'm feeling lucky"
Meaning: messages containing the phrase
"i'm feeling lucky" or "I'm feeling lucky".

Example: subject:"dinner and a movie"
Meaning: messages containing the phrase
"dinner and a movie" in the subject.

( ) Used to group words
Used to specify terms that shouldn't
be excluded.

Example: from:alex (dinner OR movie)
Meaning: messages from Alex that contain
either the word "dinner" or the word
"movie".

Example: subject:(dinner movie)
Meaning: messages in which the subject
contains both the word "dinner" and the
word "movie".

create_time:[yyyymmdd
yyyymmdd]

Search for messages created
during a certain period of time.

Example: create_time:[20110416
20110516] 
Meaning: messages created between
April 16, 2011 and May 16, 2011.

after:
before:
older:
newer:

Search for messages sent or
received during a certain period of
time 
(using the date format yyyymmdd).

Example: after:20110416
before:20110516 
Meaning: messages sent between April
16, 2011 and May 16, 2011.

More precisely: messages sent after
12:00 AM (or 00:00) April 16, 2011 and
before May 16, 2011.

older_than:
newer_than:

Similar to older and newer, but
allows relative dates using d, m,
and y for day, month, and year.

Example: newer_than:2d
Meaning: finds messages sent within the
last two days.

size: Search for messages larger than
the specified size in bytes.
Abbreviations for numbers (B, K,
M) are allowed. Size limit is
2000MB.

Example: size:300
Meaning: messages larger than 300 bytes

Example: size:[300 2000]
Meaning: messages larger than 300 bytes
but smaller than 2000 bytes.

larger:
smaller:

Similar to size, allows abbreviations
for numbers (B, K, M). Size limit is

Example: larger:1M
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Operator Definition Example

2000MB. Meaning: All messages of at least 1MB in
size.

Example: larger:150K smaller:1M
Meaning: messages larger than 150KB
but smaller than 1MB.

+
(plus sign)

Match the search term exactly. Example: +movie
Meaning: minds messages containing
“movie” but not “movies” or “movei”.

Using wildcard characters
A wildcard character is a keyboard character such as an asterisk (*) or a question mark (?) that is used to
represent one or more characters when you are searching for files, folders, printers, computers, or people.
Wildcard characters are often used in place of one or more characters when you do not know what the real
character is or you do not want to type the entire name.

Wildcard character Definition Example

*
(asterisk)

Used to substitute for zero or more
characters.

Example: subject:d*g
Meaning: finds messages containing
words "doing", "dog", "debug", etc.

?
(question mark)

Used to substitute for a single
character in a name. 

Example: subject:d?g
Meaning: finds messages containing
words "dog", "dig", "dug", etc.

Note
Other special characters are not used for search. Search query, containing special characters, may
return incorrect result. Search queries, which contains special characters, should be entered in quotes ("
")

Note
Doesn't use question mark (?) at the start of the word. Question mark (?) works only for search queries,
which contains 1 word.
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Search within attachments
Search within attachments is not enabled by default. This option can be changed in the Options menu.
This option allows to perform search in attachments’ content.

Note
After enabling this option the database will have to be reopened. Search process may take longer when
search within attachments is enabled.
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Extended search
‘Extended search’ option is not enabled by default. This can be changed in ‘Options’ menu.
‘Extended search’ option is intended to improve search results when performing search in double byte
language, e.g., Japanese or Chinese. 

Note
‘Extended search’ option supports search in the following fields: ‘From’, ‘Subject’, ‘To’. Search process
may take longer when this option is enabled.

Note
Asterisk and Question Mark doesn't supported in Extended search mode.
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5 Exporting items
Arcserve Exchange Granular Restore Tool includes the injection capability for items (emails, calendars,
contacts, etc.) from offline database to original live Exchange databases as well as granular data extraction to
Personal Storage File (.pst) files.

5.1 Restore to original live Exchange Server. Standard mode

Important Note
Standard export mode requires access to Active Directory to establish connection to Exchange Server.
The program requests users list from Active Directory and checks if IDs of offline and live user mailboxes
match. That's why the user, logged in, must be a domain user.

After startup, opening an EDB file and checking items the main window of the application looks as follows:

Clicking the injection button will bring up the following dialog:
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Domain name of the machine with Exchange Server will be automatically detected if current machine is in the
same domain with Exchange Server. Otherwise, the host will not be detected and has to be entered manually.
By default, Arcserve Exchange Granular Restore Tool uses current user to establish the connection. If current
user doesn't have rights to impersonate selected for export user, an appropriate error will appear in details.
In case of error it is recommended to use the Advanced button and configure the connection settings.

There are two ways to connect to selected mailbox: 
1. Use credentials of selected mailbox. 
2. Specify the user that has impersonation rights. 
To use credential of selected mailbox, enter host name of machine with Client Access Role, unmark Use
current Windows credentials enter user name and password and press Connect. 
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To use Exchange impersonation to establish the connection, enter host name of machine with Client Access
role, unmark Use current Windows credentials, enter credentials of the user with impersonation rights and
press Connect. In the example below Brian has impersonation rights to access Dalia's mailbox. 

Exporting to live Exchange is also available via the File menu.
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After establishing the connection, the export will start. Required time depends on how many items are selected
for export. You will be shown a progress window during the export. The window shows the number of saved
folders, messages, errors and total expected items to be restored. You can disable the progress window
directly in the window or go to the Options menu and select Show progress dialog. 
The export can be canceled by clicking the Cancel exporting button on the taskbar. 
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Note
Work with disabling/removing users:

· In case removing user and creating new user(mailbox) with same name and attributes, product can't
export into original location. Please use Expert mode.

· In case disabling user and creating new mailbox using existing user (disabling user), product also can't
export into original location, because Exchange Server creates new mailbox for this user. Please use
Expert mode.

· In case disabling user and enabling user (connected in tab "Disconnected Mailbox"), product can
export into original location.

· Product can't export items in case GUID of mailbox for export is differ from GUID of mailbox in
Exchange Server. Please use Expert mode.
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5.2 Restore to live Exchange Server. Expert mode

Arcserve Exchange Granular Restore Tool includes the injection capability for items (emails, calendars,
contacts, etc.) from offline database to live Exchange database.
The following options are presented:

· Authentication

· Connection to a mailbox using its owner credentials. To provide the connection, host (domain name or
IP), user logon name and password are required. It is also possible to connect through current Windows
credentials.

· Connection to another account mailbox by using Exchange impersonation. (http://msdn.microsoft.com/en-
us/library/bb204095%28EXCHG.140%29.aspx).

· Connecting to several mailboxes on different servers simultaneously.

· Browsing folder hierarchy of a connected mailbox, browsing folder contents and viewing message bodies
and other items (calendars, contacts).

· Creating folders in the connected mailbox.

· Drag-and-drop copying of folders and individual items from offline (source, EDB) database to the attached
mailbox (destination live Exchange server).

· To provide injection, running the application as administrator of the source exchange server or using a
machine from source AD domain with Exchange Server and source mailbox, is not required.

· Injection is possible to a local machine, as well as machines with Exchange Server, which are in the local
network or the Internet.

Important Note
Export into live Exchange Server is based on mailbox GUID and mailbox address. In case if the original
mailbox GUID differs from the the appropriate mailbox GUID in Exchange Server, the warning dialog will
appear.
GUID of mailbox in opened .edb file can be checked using Export into original mailbox in the product.
GUID of live mailbox in Exchange Server can be found using the following Exchange PowerShell cmdlet:
Get-Mailbox -id <mailbox_name> | fl *guid*.

http://msdn.microsoft.com/en-us/library/bb204095%28EXCHG.140%29.aspx
http://msdn.microsoft.com/en-us/library/bb204095%28EXCHG.140%29.aspx
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Connection to Exchange Server
After opening a mail store the main window of the application looks as follows: 

There is a panel with a wide splitter added on the right. Toolbar buttons are added to connect to Exchange
Server and inject checked items to the attached mailbox.
The injection button (next to the Export selected data into PST button) becomes active when there is a
connection with at least one live mailbox and items in the offline database are checked.
The button for the connection to the mailbox has a drop-down list with mailboxes, which were attached
previously. When clicking Select menu item for the attached mailbox in the drop-down list, it appears in the
tree on the right and becomes selected. It is also possible to disconnect from the mailbox by clicking the
Disconnect menu item.

Clicking the connection toolbar button will bring up the following dialog for entering the credentials:
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Fill the following required fields:
• Host: domain name of the machine with Exchange Server, or IP address
• User logon name – user name to log on
• Password - user’s password
There is an option of connecting using current Windows credentials. When the checkbox is selected, the
User and Password fields are disabled:

It is possible to connect to someone else’s mailbox using Exchange impersonation. To do this, check the
Connect to a different mailbox box and enter the mailbox owner SMTP address:
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Connecting and exporting to live Exchange are also available through the File menu.



Arcserve Exchange Granular Restore Tool

Page 44Version 22.2.0

Injection workflow
After the connection is established, the mail store tree appears on the Destination tab (1). It will be listed in
the drop-down list of the toolbar (2) connection button and in the File menu (3).

It is possible to select whether to show folder items and preview or not – a button near the Destination tab is
used for this purpose. If it is disabled there will be only a tree displayed in the right panel.

After enabling the button a list with the items is displayed as well as a preview when clicking on the item.
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Connection to several mailboxes simultaneously on different hosts is possible.

After mailbox appears in the tree, it is possible to drag-and-drop folders and separate items. When dragging a
folder or a mailbox to live Exchange mailbox, the hierarchy of the data being dragged will be recreated inside
the destination folder.
When right-clicking folders/mailboxes in the destination panel, it is possible to create a folder inside the
mailbox.
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It is also possible to delete and rename created folder within one program session. When checking the items
in the offline database, data exporting is available by clicking the Export into live Exchange Server mailbox
button. This method is the equivalent of saving to PST, except that the target is a live server, not a file. It is
complementary to drag-and-drop and useful for management of disparate data. With this method, items of
different types (e.g. notes and tasks) and/or located in different offline database folders/mailboxes can be
exported.

When clicking the Export into live Exchange Server mailbox button, a dialog, which allows to select a folder
to save selected data, appears. Data hierarchy will be restored automatically. The root of hierarchy is the
closest common parent item.
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5.3 Working with clustered Exchange Server configuration

Exporting data into live instance of clustered Exchange Server does not differ from working with any other
server configuration. Even if there are several servers with Mailbox Server roles in your configuration, and
they have been added to your CCR/DAG, data can be easily restored.

As you can see on the scheme, to export data into live server, Arcserve Exchange Granular Restore Tool calls
Client Access Server to get access to specified mailbox. And it doesn't really matter which of existing Mailbox
Servers stores target mailbox - data will be exported to the right place. 
The IP-address or FQDN of Client Access Server should be specified in the Host field while using the Expert
mode. In the Export into original mode FQDN of this server is detected automatically by calling Active
Directory domain controller.
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5.4 Restore to PST files

To save items marked for export, click the Export selected items into PST button on the toolbar or select the
item in the File menu.

You will be asked to select or create the destination folder for recovered data:

After selecting folder, the export will start. Required time depends on how many items are selected for export.
You will be shown a progress window during the export. The window shows the number of saved mailboxes,
folders, messages and total expected items to be restored (1). You can disable the progress window directly in
the window or go to the Options menu and select Show progress dialog.
The export can be canceled by clicking an appropriate link in the progress dialog window (2) or by clicking
the Cancel export button on the taskbar (3).
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Tip
If you closed the progress window, it can be shown again by clicking on the progress bar on the status
panel.
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PST file naming, size and format
Arcserve Exchange Granular Restore Tool exports each mail store into a separate .pst file named “Recovery
NNN - <Mailbox Name>[ - VVV] . pst”, where NNN is current recovery session identifier, VVV – volume
number in case the PST has to be written in more than one volume.
Example:
Recovery 001 - John Doe.pst
Recovery 001 - John Doe - 001.pst
Recovery 001 - John Doe - 002.pst
Recovery 001 - Mary Smith.pst
With large exports, there can be more than one file on the output. Additional files are created automatically
when the file size limit is hit. The size volume limit depends on the output file encoding. For ANSI PST files the
limit is 1GB, for Unicode files it is 19GB.
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Opening exported items in Outlook
To view and manipulate exported items, use Microsoft Outlook to open the Personal Storage File (.pst) files
exported by Arcserve Exchange Granular Restore Tool:

1. Start Outlook.
2. Click File and choose Open Outlook Data File.
3. Select exported pst file and click OK.

Note
It is not recommended to move .pst files that are open in Outlook. Before moving, right-click the name of
the Outlook Data File (.pst) and click Close.
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Restoring exported items into Exchange Server
Items extracted from a mail store can be easily restored into a live server:

1. Make sure you have Microsoft Outlook with access to the mailbox you want to restore items into.
2. Open .pst file with exported messages.
3. Open the mailbox you need to import data into.
4. Select the items and drag-and-drop them back into the original folders. They will be automatically

synchronized with the live Exchange Server database.
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6 Command-line interface
The command line feature allows you to easily process several databases.
Usage: esr.exe <source> <destination>
Example: esr.exe "c:\Mailbox Database.edb" "c:\results\"
Below is a list of commands with their description that can be used in command line:

· There are s everal ways to set the source file(s):

Operation Description Example

<file mask path> mask to path with files esr.exe c:\*.edb c :\results\

/list=<path>
sets a path to file that contains a list
of files to recover

esr.exe /list=d:\files_to_recover.txt
c:\results\

/list={file1, file2, …, fileN}
sets enumeration of files to
recover. Full path to file must be
used

esr.exe /list={d:\1.edb, d:\2.edb} c:
\results\

· Specify the destination directory for the recovered file(s):

Operation Description Example

<out dir> path to output directory esr.exe c:\*.edb c :\results\

· Detailing parameters:

Operation Description Example

/initdir=<path>
sets the initial directory for the
Open database dialog

esr.exe /initdir="c:\EDB Mailboxes\"

-notfilterfaultymessages shows messages that have been
filtered due to their damage

esr.exe -notfilterfaultymessages 

/redirect=<path> redirects console output to text file
esr.exe c:\*.edb c :
\results\ /redirect="c:\result.txt"

/cleartemp if set - the product will remove all
temp data on startup

esr.exe /cleartemp

/inputfile=<path to file> program starts and opens the
specified file

esr.exe /inputfile="c:\EDB
Mailboxes\Mailbox Database.edb"

/transactionlogsdir=<path to logs>
program starts and opens the
specified file with its transaction
logs

esr.exe /inputfile="c:\EDB
Mailboxes\Mailbox
Database.edb" /transactionlogsdir=
"c:\EDB Mailboxes\"
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7 Glossary
This glossary lists terms and their synonyms, most commonly used in Arcserve Exchange Granular Restore
Tool help.
AD - Active Directory (AD) is a directory service implemented by Microsoft for Windows domain networks. An
AD domain controller authenticates and authorizes all users and computers in a Windows domain type
network.
ANSI PST format - An old PST-file format, used in Outlook 97-2002. ANSI format has a 2 GB limit in file
size. 
Deleted items - Items/folders deleted from a mailbox hierarchy.
Destination folder/mailbox - A folder/mailbox, selected for export.
EDB - An Exchange database format, used to store information from users’ mailboxes. Synonyms: Exchange
Server database, dataset.
EWS - Exchange Web Services. EWS provides the functionality to enable client applications to communicate
with the Exchange server. EWS provides access to much of the same data that is made available through
Microsoft Office Outlook.
Exchange impersonation - Exchange impersonation enables a caller to impersonate a given account so that
the operations can be performed with the rights of the impersonated account, instead of the rights that are
associated with the caller's account. Configuration information is available at http://msdn.microsoft.com/en-
us/library/office/bb204095(v=exchg.140).aspx
Exchange Server - A mail server, calendaring software and contact manager developed by Microsoft.
Export - Copying information from an offline mailbox so it can be stored in a pst file or on the live Exchange
Server.
GMT - Greenwich Mean Time (GMT) is considered as a reference point for time.
Host - Domain name of the machine with Client Access role of Exchange Server, or IP address.
Injection - The process of copying data from offline mailbox to live or original connected mailbox on the
server.
Local time - Local time is calculated by adding or subtracting a number of hours, depending on a time zone,
to UTC.
Live Exchange Server mailbox - Destination Exchange server mailbox, that exists on the server and is
available for connection. Synonym: attached mailbox.
Mail Store - A type of self-storage whereby customers send items by mail or delivery service (usually by the
box) to be stored at a central location. Synonyms: mailbox, offline database, database storage (depending on
the context). 
Original mailbox - A mailbox in live Exchange Server that corresponds to the mailbox in the opened database.
PST - A Personal Storage File (.pst) format, used to store copies of messages, calendar events, and other
items. PST files are readable with Outlook or other compatible email client.
Unicode PST format - A PST-file format used in Outlook 2003, Outlook 2007, Outlook 2010, Outlook 2013,
Outlook 2016 and Outlook 2019, so older versions of Outlook will not be able to open Unicode formatted PST
files. Previous versions of Outlook were using ANSI format. The main reason for this change was to allow for
international character support and to extend the maximum size of PST files beyond the 2GB limit of the ANSI
formatted PST files.
UTC - Coordinated Universal Time (UTC) is the primary time standard by which the world regulates clocks
and time. Usually used with references to time zones.
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