自動保護で VM の検出と保護に失敗する
仮想マシンが検出されないため、自動保護の一部として自動的に保護されます。
現象
VM は、ハイパーバイザ(vCenter/ESX または Hyper-V)でネイティブ クライアント アプリケーション(たとえば、vSphere Client や Hyper-V マネージャ)によって表示できますが、自動保護で検出されないため、VM を自動的に保護することはできません。
原因
- VM には、ハイパーバイザで有効なステータスがありません。たとえば、自動保護では、vCenter/ESX で切断、不明またはアクセス不可のステータスである VM はスキップされます。
- VM は、仮想スタンバイ(VSB)、インスタント VM (IVM)、アシュアード リカバリ(AR)などの Arcserve UDP タスクによって作成されます(または VSB/IVM/AR VM からクローニングされます)。Arcserve UDP は、以下の点を考慮して意図的にこのような VM をスキップします。
- VSB/IVM/AR によって無制限に作成される Arcserve UDP のバックアップ VM は、無限バックアップ ループを引き起こす可能性があります。たとえば、自動保護を使用して ESX 全体を保護します。バックアップ プランでバックアップ タスクを追加した後、同じ ESX に VSB VM を作成する VSB タスクを追加します。この場合、最初のバックアップ後に新しい VSB VM が ESX に作成されます。新しい VSB VM は自動保護によって検出され、バックアップ プランに追加されます。次に、次回のバックアップ中に以前の VSB VM の新しい VSB VM が作成され、バックアップ プランに追加されます。ESX ストレージの空き容量がなくなるまで、この処理が続行されます。
- Linux IVM/AR VM では、ストレージ マイグレーションで通常の VM に変換しない限り、Arcserve UDP は VM をバックアップできません。バックアップ ジョブは完了しますが、バックアップされた復旧ポイントはリストアできません。このような状況は、Linux IVM 実装の技術的な制限により発生します。
解決策
VSB/IVM/AR VM をバックアップする場合や、クローニングまたはストレージ マイグレーションによって VM を独立した VM に変換する場合は、以下に示す手順に従って、vSphere VM および Hyper-V VM が自動保護で検出および保護されるようにすることができます。
vSphere VM の場合
- vSphere Web クライアントにログインし、VM を見つけます。
- VM の電源をオフにします。
- VM を右クリックし、メニューから[設定の編集]を選択します。
- [VM オプション]タブを選択し、[拡張]を展開します。
- [構成の編集]をクリックします。
- 構成パラメータのダイアログ ボックスで、以下の名前のパラメータを探します。
- VCM
- UDP_IVM
- UDP_ARVM
- UDP_IVM_LINUX
- UDP_VSBVM
- UDP_ARVM_LINUX
- UDP_ARIVM_LINUX
- パラメータの値をクリアし、[OK]をクリックして保存します。
Hyper-V VM の場合
- Hyper-V ホストにログインし、Hyper-V マネージャを開きます。
- VM を見つけます。
- VM を右クリックし、メニューから[設定]を選択します。
- [設定]ダイアログ ボックスの左側のパネルで[名前]を選択します。
- 以下の文字列で始まるすべての行を削除します。
- VCM
- UDP_IVM
- UDP_ARVM
- UDP_IVM_LINUX
- UDP_VSBVM
- UDP_ARVM_LINUX
- UDP_ARIVM_LINUX
- [OK]をクリックして保存します。